ICL SFTP unavailable

Incident Report for RevSpring

Resolved

Issue has been resolved and FTP server(s) are once again available to the clients.
Posted Jul 24, 2026 - 16:44 CDT

Identified

Users are experiencing issues logging into SFTP. We expect to have the issue resolved shortly.
Posted Jul 24, 2026 - 16:01 CDT
This incident affected: Print & Mail File Processing (ICL Platform (Livonia, MI)).