Security Warning Messages - PersonaPay Patient Portals

Incident Report for RevSpring

Resolved

This incident has been resolved.
Posted Jul 06, 2026 - 09:55 CDT

Monitoring

We believe the issue has been corrected and are continuing to monitor the portals to confirm normal access remains stable.
Posted Jul 02, 2026 - 16:13 CDT

Identified

We are currently investigating intermittent reports of security warning messages appearing for some users when accessing PersonaPay patient portals. Our teams, are actively working with the appropriate parties to resolve the issue.

We will continue to monitor the situation and provide updates as more information becomes available.
Posted Jul 02, 2026 - 08:51 CDT
This incident affected: PersonaPay and eVokePay.